ThinkPHP 5 <=5.0.22 远程代码执行高危漏洞

日期:2019-02-27 浏览:657次

阿里云预警

ThinkPHP5 <= 5.0.22 远程代码执行高危漏洞

ThinkPHP 是一款兼容性高、部署简单的轻量级国产PHP开发框架。

2018年12月10日,阿里云云盾应急响应中心监测到ThinkPHP官方发布安全更新,披露了一个高危安全漏洞,由于ThinkPHP5框架对控制器名没有进行足够的安全检测,导致在没有开启强制路由的情况下,攻击者构造特定的恶意请求,可以直接获取服务器权限。受影响的版本包括5.0和5.1版本。当前这个漏洞影响ThinkPHP <=5.0.22版本。

官方文档:https://blog.thinkphp.cn/869075?spm=a2c4g.11174386.n2.6.30b210512TwS0c

手动修复

5.0版本

在think\App类的module方法的获取控制器的代码后面加上

if (!preg_match('/^[A-Za-z](\w|\.)*$/', $controller)) {
    throw new HttpException(404, 'controller not exists:' . $controller);
}

5.1版本

在think\route\dispatch\Url类的parseUrl方法,解析控制器后加上

if ($controller && !preg_match('/^[A-Za-z](\w|\.)*$/', $controller)) {
    throw new HttpException(404, 'controller not exists:' . $controller);
}

没有评论

发表评论